We will be undergoing scheduled maintenance during this time.
Posted Nov 04, 2025 - 19:06 CST
Scheduled
Dear Customer, Please be advised of an upcoming scheduled planned maintenance event affecting our IAD (Middletown) Data Center:
📅 Date: December 8, 2025 – December 12, 2025 ⏰ Time: 7:00 AM CST – 4:00 AM CST 📍 Location: IAD (Middletown, VA) 🔧 Affected Services: Generator Maintenance ⚠️ Expected Impact: No disruption is anticipated, but the potential exists.
What’s Happening? CCS Data Center Partner will conduct a test that involves transferring the facility load from utility power to generator power. During the transfer, all customer equipment will remain supported by Uninterruptible Power Supply (UPS) systems to ensure continuity. No interruption is expected. However, customers should be aware that any transition between power sources carries a minimal risk of disruption. In the event of an unexpected utility failure during the maintenance window, the load will be automatically transferred to reserve generators.
How You’ll Be Notified: ✅ Initial Notification – Sent upon scheduling of the upcoming maintenance work. ✅ 1-Hour Reminder – A reminder notification is sent one hour before the start of the maintenance window. ✅ Start Notification – Issued at the beginning of the maintenance to confirm that the work is underway. ✅ Completion Notification ("All Clear") – Sent once maintenance is complete and all services are confirmed to be operational. Our team will actively monitor the situation and remain in contact with the CCS Data Center Partner. Should you have any concerns, please reach out: 📧 support@cirrascale.com
Thank you for your understanding and continued partnership. Connor Taylor Network Operations Supervisor Cirrascale Cloud Services Email - support@cirrascale.com
Posted Nov 04, 2025 - 19:05 CST
This scheduled maintenance affects: Middletown (IAD) (Power Infrastructure).