IAD01 - CCS Maintenance Notification - Power System Testing (12/8/25 –12/12/25)

Scheduled for Dec 8, 07:00 CST  -  Dec 12, 16:00 CST

Update

We will be undergoing scheduled maintenance during this time.
Posted Oct 31, 2025 - 14:51 CDT

Scheduled

Dear Customer,
Please be advised of an upcoming scheduled planned maintenance event affecting our IAD (Middletown) Data Center:

📅 Date: December 8, 2025 – December 12, 2025
⏰ Time: 7:00 AM CST – 4:00 PM CST
📍 Location: IAD (Middletown, VA)
🔧 Affected Services: Generator (Power System Maintenance)
⚠️ Expected Impact: No disruption is anticipated, but the potential exists.

What’s Happening?
CCS Data Center Partner will perform planned power system maintenance from Monday, December 8 through Friday, December 12, 2025, between 8:00 AM and 5:00 PM EST. During this time, facility load will be transferred from utility power to generator power for testing.

All customer equipment will remain supported by UPS systems, and no service impact is expected. However, as with any power transition, a minimal inherent risk exists. CCS Data Center Partner staff will closely monitor all systems and take immediate action if any irregularities occur.

No customer action is required, though we recommend avoiding major maintenance or power-sensitive changes during this period.

How You’ll Be Notified:
✅ Initial Notification – Sent upon scheduling of the upcoming maintenance work.
✅ 1-Hour Reminder – A reminder notification is sent one hour before the start of the maintenance window.
✅ Start Notification – Issued at the beginning of the maintenance to confirm that the work is underway.
✅ Completion Notification ("All Clear") – Sent once maintenance is complete and all services are confirmed to be operational.

Our team will actively monitor the situation and remain in contact with the CCS Data Center Partner. Should you have any concerns, please reach out:
📧 support@cirrascale.com


Thank you for your understanding and continued partnership.

James Cobb
Network Operations Manager
Cirrascale Cloud Services
Email - support@cirrascale.com
Web - http://www.cirrascale.com
For additional information, please visit the following link to your Jira ticket: Requests - Jira Service Management
Posted Oct 31, 2025 - 14:48 CDT
This scheduled maintenance affects: Middletown (IAD) (Power Infrastructure).